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Features 

SQL Editor   - Executes SQL statements, SQL scripts and PL/SQL blocks. 

Schema Explorer  - Explores Database objects. 

Session Manager  - Shows information about Sessions. 

Space Manager - Shows utilized and free Tablespace using pie charts. Shows objects in 

each Tablespace. 

User Manager   - Shows Profiles, Users, Roles and Privileges. 

SGA Display   - Shows information about SQL statements. 

Instance Details  - Shows Oracle parameters and buffers using pie chart. 

Server Statistics  - System Statistics and system wait time. 

Performance Monitor  - Shows Oracle performance using graphs, bar charts & pie charts. 

System Waits - Shows Session level and System wide waits in the database using pie 

charts. 

Top 5 SQL   - Shows Top 5 Sqls in four categories using interactive 3-D bar charts.    

Server Tuning   - Shows Physical i/o, Logical i/o and CPU, Elapse Time of all SQLs. 

Top 5 Resource - Shows Top 5 Resource Usage sessions in four categories using 

interactive 3-D bar charts.       

Resource Usage  - Shows Resources used at Session level and System wide. 

Text Editor   - Simple Text Editor to view result data files. 

DB Activity - Shows database activity in real time using interactive graphs (Logical 

I/O, Physical I/O, Event Waits, Latches etc..) 

Wait Analysis - Shows mostly Wait Classes, CPU Usage, Events, Objects, Sessions 

and SQL statements... 

Top Ten SQL - Shows Top Ten SQLs in nine different categories using interactive 2-D / 

3-D pie charts 

Blockers Waiters - Shows Session Blockers, Session Waiters, Locks and Long Running 

Queries. 

 

MyOra is built on Multithreading, Multiple Document Interface (MDI) framework, which can handle multiple 

sub-windows opened at the same time. MyOra allows multiple connections to the same database or 

different database. MyOra’s MDI framework provides most easy to use and easy to manage user 

interface when working with multiple sub-windows. Sub-windows can be arranged and viewed vertically 

or horizontally. Any sub-window can be minimized, maximized or closed at the click of a button. 
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 MyOra’s MDI framework allows to monitor performance of multiple databases same time. Also, users can 

run SQL queries while monitoring the database. Up to maximum of 100 sub-windows can be opened at 

the same time. These sub-windows are of any combination Performance Monitor, Schema Explorer, 

Session Monitor and SQL Editors, etc…. 

 

For Example: Users can open two Schema Explorers and view vertically or horizontally. One Schema 

Explorer for SCOTT@DBDEV and the other Schema Explorer for SYSTEM@DBPROD.  

 

Connecting to the Database 

Login  

MyOra can connect to database using three different connection modes: The connection modes 

are Basic, TNS Names and JDBC URL. 

 

To Login to the database 

1. On the toolbar, click the icon . 

OR 
On the File menu, click New Connection 

2. Database Login popup window is displayed. 

3. On Database Login popup window, enter Connection Name (optional), User Name, 

Password and Connection Type (NORMAL, SYSDBA and SYSOPER). 

4. Click one of three Connection mode Tabs and enter data. If you enter data in more than 

one tab will results in an error message. 

 
a. Basic mode: 

 
Basic mode connection do not require any Oracle client software on local computer. 
 
 Enter ‘localhost’ in Hostname field, if Oracle database resides on the same 

machine. 
Enter ‘Server name’ in Hostname field, if database resides on another machine. 

 Enter 1521 in Port field. 

 Enter ‘database name’ in Database Name (SID) or Database Name (Service 

Name) field. 

 
Example 1: If you are connecting to the database MYDEV located on your 
Personal Computer then, enter: 
Hostname: localhost 
Port: 1521  
Database Name (SID): MYDEV 

 
Example 2: If you are connecting to the database WORKDB located on server 
SRVR01 then, enter: 
Hostname: SRVR01 
Port: 1521 
Database Name (SID): WORKDB 
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Example 3: If WORKDB database has service name WORKDB.SALES, then 
enter: 
Hostname: SRVR01 
Port: 1521 
Database Name (Service Name): WORKDB.SALES 
 

b. TNS Names mode: 
 
MyOra can connect to Oracle database using tnsnames.ora file. This file normally 
resides in the $ORACLE_HOME\network\admin\ directory. 
 
 Enter database name in Database field. 
 Enter file path of tnsnames.ora file in Tnsnames File field. 

 

Example: Sample tnsnames.ora file path in windows based system is shown 
below. 
C:\OraHome\network\admin 

 
c. JDBC URL mode: 

 
MyOra can connect to Oracle directly using JDBC URL string. 
 
 Enter connection string in JDBC URL field. 

 
Example: 
jdbc:oracle:thin:@localhost:1521:MYDEV 
jdbc:oracle:thin:@ServerName:1521:WORKDB 
 

ServerName = Name of the database server. 

 

New SQL Editor Window opens after successful login. 

 

Login History 

MyOra stores history of logins to the database using Connection Names. Every login to the 

database is identified by unique Connection Name. All previous Connection Names are available 

in Login History Grid for quick login. 

To Login to the database using Login History 

1. On the toolbar, click the icon . 

OR 
On the File menu, click New Connection. 

2. On Database Login popup window. Click the desired connection row. 

a. User Name, Connection Type (NORMAL, SYSDBA and SYSOPER) and 

Connect mode tab are populated. 

3. Click Connect button. 
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Connection Indicator 

Connection Indicator field is located on top right corner of MyOra screen. This field shows User 

Name and Database of the current connection. The Connection Indicator field is a List box 

(dropdown) field which contains all MyOra unique connections to database(s). 

 

 

Example 1:  If User SCOTT has login to DBTEST and DBQA databases, User SYSTEM has login 

to SALESDB and HRDB, then Connections Indicator list box contains SCOTT@DBTEST, 

SCOTT@DBQA, SYSTEM@SALESDB and SYSTEM@HRDB. 

 

Using Connection Indicator field you can choose required connection and then open different 

features (like Schema Explorer, Session Manager, etc...). 

 

The following example will show how Connection Indicator is useful when multiple MyOra 

connections exist. 

 

Example 2: If User SCOTT is already login to DBTEST and DBPROD databases and currently 

working with SQL Editor(s). If SCOTT wants to open a Schema Explorer for DBTEST, then 

SCOTT must choose SCOTT@DBTEST connection from the dropdown list and click Schema 

Explorer icon . 

 

Closing the Connection 

Connection Close icon  allows you to close the database connection for a selected 

connection from Connection Indicator dropdown list. The connection to a database will be closed 

only after closing all features (Schema Browser, Session Manager etc...) for that connection. A 

pop up message will be displayed, if you try to close the database connection when an open 

feature still exists. 
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SQL Editor 

The SQL Editor lets you do the following 

 Write and execute SQL statements. 

 SQL syntax highlighting. 

 Open and execute the script file. 

 Save SQL Statements to a file. 

 View History of SQL statements. 

 View result data in vertical format (Single Record view). 

 Export result data grid to a Text file or CSV file. 

 Run PL/SQL blocks and view DBMS.PUT_LINE statements in DBMS output. 

 Run multiple SQL statements as script. 

 Recalls previously run SQL Statements. 

 Explains execution plan of SQL statement. 

 Shows statistics of the SQL execution. 

 

 

The SQL Editor also has other features 

 Invoke multiple Table Describe popup windows. 

 Invoke Tables & Views Tree popup window. 

 Invoke Table Auto completion popup. 

 Invoke Column Auto completion popup, if the tables are qualified in SQL statement. 

 Shows SQL Execution Indicator icons  or  in SQL Editor’s left margin. 

 Scans SQL statements for bound variables and asks for input values before execution. 

 Displays the result row count in the status bar of the editor. 

 Shows statistics of the SQL statement. 

 Sorts the result data by column.   

 

SQL Execution indicator 

Execution Indicator is shown in the margin area of SQL Editor at the first line of SQL statement. 

1. The icon turns green, if the statement is executed successfully. 

2. The icon  turns red, if an error occurs during execution. 

 

Executing SQL statements 

SQL statements can be executed in three different modes, Single Statement Mode, Current 

Statement Mode and Script Mode. Semicolon (;) at end of each SQL statements is not required. 

 

 

A. Single Statement Mode:  

1. Write SQL statement in the SQL Editor window. 

2. Click the icon  to execute the statement. 
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3. In this mode the entire SQL Editor window is read as one SQL statement. 

4. The icon  turns green, if the statement has executed successfully. 

5. The icon  turns red, if an error occurs during execution. 

 

B. Current Statement Mode: 

1. Write multiple SQL statements in the SQL Editor window separated by a blank line. 

2. Place the cursor anywhere on the preferred SQL statement. 

3. Click the icon  to execute the statement. 

4. In this mode the current SQL statement is read and processed for execution. 

5. The icon   turns green, if the statement has executed successfully. 

6. The icon  turns red, if an error occurs during execution. 

 

C. Script Mode: 

1. Write multiple SQL statement in the SQL Editor window separated by slash ‘/’. 

2. Click the icon  to execute the script. 

3. Result of each SQL statement is written to the Output Tab. 

4. If an error occurs at any SQL statement, then a message will prompt you to Continue or 

Skip the error or Cancel. 

 

Result Data Navigation buttons 

Four result data navigation buttons First, Next, Previous and Last are located above the Result 

gird for easy access of the result rows. These buttons are also used in Single Record tab. 

To navigate on Result data set: 

1. Click  icon to advance on row. 

2. Click  icon to go to last row. 

3. Click  icon to go to previous row. 

4. Click  icon to go to first row. 

 

To view Result data in vertical mode: 

1. Click Single Record tab. 

2. Click  icon to advance on row. 

3. Click icon to go to last row. 

4. Click  icon to go to previous row. 

5. Click  icon to go to first row. 
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Result Data grid Data/Time format 

The default Date format for Result Data grid is DD-Mon-YYYY. You can use Options window 

(Navigate to Tools -> Options) to change the default settings. 

 

The available Date/Time formats are 

  DD-Mon-YYYY 

  DD/MM/YYYY 

  MM/DD/YYYY 

  YYYY-MM-DD 

  YYYY/MM/DD 

  YYYY-MM-DD HH:MI:SS AM 

  YYYY-MM-DD HH24:MI:SS 

  YYYY/MM/DD HH:MI:SS AM 

  YYYY/MM/DD HH24:MI:SS 

  HH:MI:SS AM 

  HH24:MI:SS 

 

Export Result data 

Result data can be saved to Text file or CSV file. 

To save result data to a file: 

1. Right click anywhere on the result data grid. 

2. A popup menu appears with items Save to Text file and Save to CSV file. 

3. Click the preferred item. 

4. Enter filename in save popup and click the Save. 

 

Note: The exported data to the text file can be best view using any ‘Text Editor’ software with 

Courier (Regular) font size 10. 

 

Describe 

Tables and Views can be described in the SQL Editor window.  

To describe a Table or View do the following: 

1. Place the cursor on table (or view or synonym), right click for pop-up menu, click 

Describe. 

OR 

Place the cursor on table (or view or synonym), click SQL Editor menu, click Describe. 
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OR 

Place the cursor on table (or view or synonym), on the toolbar, click the icon . 

2. A popup window is displayed with column names and column size. 

3. This window has multiple tabs with information on Index, Script, Triggers, Constraints, 

Privileges, etc. 

4. Multiple Describe popup windows can be displayed. 

 

To add a column from the Describe window to the SQL Editor 

1. Position and click the cursor at the preferred location on the SQL Editor. 

2. Double click or drag the table column to append in the SQL Editor at the current cursor 

location. 

 

Table & View Tree 

To view Tables and Views of the current database 

1. On the toolbar, click the icon . 
OR 
On the SQL editor menu, click Table & Views. 

2. A schema tree is displayed in a popup window. 
3. Click the specific username in the schema tree. 

4. Click the Table or View name. 

 

To add a Table or View to the SQL Editor 

 

1. Position and click the cursor at the preferred location on the SQL Editor. 

2. Double click or drag the Table or View to append in the SQL Editor at the current cursor 

location. 

 

To view Columns & Indexes 

 

1. Explore the Table name. 

 

To add a Column from the Table or View to the SQL Editor 

 

1. Position and click the cursor at the preferred location on the SQL Editor. 

2. Double click or drag the column to append in the SQL Editor at the current cursor 

location. 

 

Explain Plan 

To view the execution plan of the SQL 

1. On the toolbar, click the icon . 
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OR 

On the SQL editor menu, click Explain Plan. 

OR 

In the Results section, click Explain Plan Tab. 

 

Table Auto Completion 

To activate Table auto completion wizard on SQL Editor window 

1. Type User Id. 

2. Type a dot (.) after User Id. 

3. The Table auto completion wizard is activated and a popup window is displayed with 

table names for the User Id.  

4. The table names can be filtered by typing the letter(s) after the dot.  

5. Click the table name in the popup window, to append at the current cursor location on the 

SQL Editor. 

 

Column Auto Completion 

To activate Column auto completion wizard on SQL Editor window 

1. Type Table name. 

2. Type a space, then type qualifier (any word or any character). 

3. Then type qualifier anywhere in the SQL statement. 

4. Type a dot (.) after qualifier. 

5. The column auto completion wizard is activated and a pop window is displayed with 

column names from the qualified table. 

6. The column names can be filtered by typing the letter(s) after the dot. 

7. Click the column name in the popup window, to append at the current cursor location on 

the SQL Editor. 

 

Vertical Scrollbar 

The vertical Scrollbar of result data grid works in two different modes.  
 

1. If the current result data grid row is the last visible row, click the down arrow button of the 

scrollbar to add next 50 rows to the current result data grid.  

2. To add all result rows to the result data grid, drag down the thumb of the vertical scroll 

bar. 

 

SQL Logging (History of SQLs) 

To view the history of SQL Statements 
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1. In the lower half of the SQL Editor, click on the SQL Logging tab 

a. The SQL Logging tab displays 

 SQL statement 

 SQL Status 

 SQL return code is stored in case of an error 

 Timestamp 

 Duration 

 

2. To Append the SQL statement to the SQL Editor  

a. Right click on SQL statement 

b. A Popup menu is displayed with Append and Replace options. 

c. Click on Append to append SQL statement at the end in the SQL Editor 

 

3. To Replace the SQL statement in the SQL Editor  

a. Right click on SQL statement 

b. A Popup menu is displayed with Append and Replace options. 

c. Click on Replace to replace all the SQL statements in the SQL Editor with the 

selected SQL statement 

Note: SQLs run in the Script Mode are not logged  

 

Recall SQL Statements 

To Recall SQL statement 

1. On the toolbar, click the icon . 

OR 

On the SQL editor menu, click Recall SQL. 

 

Recall SQL popup window is displayed with fields. 

 Database 

 SQL statement  

 SQL Status 

 Timestamp 

 Duration  

 

2. To append the SQL statement to the SQL Editor  

a. Right click on SQL statement. 

b. A Popup menu is displayed with Append and Replace options. 

c. Click on Append to append SQL statement at the end in the SQL Editor. 

 

3. To replace the SQL statement in the SQL Editor  

a. Right click on SQL statement. 

b. A Popup menu is displayed with Append and Replace options. 

c. Click on Replace to replace all the SQL statements in the SQL Editor with the 

selected SQL statement. 
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Note: SQLs run in the Script Mode cannot be recalled. 

 

Result Column Sort 

To Sort Result data 

1. Click on Result data column header. 

2. A Popup menu is displayed for the Column Name with popup menu items By Ascending 

and By Descending options. 

3. Click on By Ascending or By Descending to sort the data. 

 

PL/SQL processing 

PL/SQL block is executed similar to SQL statement in Single Statement Mode, Current 

Statement Mode and Script mode.  

 If you use DBMS_OUTPUT.PUT_LINE statement in your PL/SQL block, then the output 

is displayed in the DBMS Output tab.  

 

 

Note: PL/SQL statements must end in a semicolon (;). 

 

DBMS Output 

To display the output in the DBMS Output tab, the server output must be turned ON. 

1. To turn server output ON  

Click on the toggle server icon to turn ON. When server output is ON, the icon 

turns green.  

2. To turn server output OFF 

Click on the toggle server icon to turn OFF. When server output is OFF, the icon 

turns red.  

3. Click the icon  to change the output Buffer size. A popup window prompts you to 

accept the default value or change the Buffer size to a new value.  

4. To change the output Pooling Frequency, slide the pointer to any preferred position 

between 2 and 16 seconds. 

Note: Server output must be ON before executing the PL/SQL block to view the contents of 

DBMS Output. 
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Statistics 

To display the statistics, first turn ON Statistics. 

1. To turn statistics ON  

Click on the toggle statistics icon to turn ON. When statistics is ON, the icon 

turns green.  

2. To turn statistics OFF 

Click on the toggle statistics icon to turn OFF. When statistics is OFF, the icon 

turns red.  

3. Execute any SQL statement in the SQL Editor window. 

4. Click the Statistics Tab to see statistics for current SQL statement. 

 

Substitution variables and Bind variables 

If SQL statement contains any Substitution variables, SQL Editor prompts for data for each 

Substitution variable. The data entered for Substitution variables are resolved into SQL text. 

Bind variables are also treated similar to Substitution variables. 

Note: The prompt data must be enclosed in single quotes for Character type and Date type fields. 

 

SQL syntax highlighting 

Default SQL text highlighting colors as described below. 

 SQL Reserved words like SELECT, UPDATE, INSERT, DELETE, etc. are highlighted in 

Blue color. 

 Any text between single quotes is highlighted in Red color. 

 Single commented SQL statements (text after --) are highlighted in Green color and the 

font is shown in Italic. 

 Multiple line commented SQL statements (text between /* and */) are highlighted in 

Green color and the font is shown in Italic. 
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Schema Explorer 

The Schema Explorer let you 

 Explore Tables, Views, Indexes, Synonyms, Sequences, Triggers, Packages, 

Procedures, Functions, Java Source, Java Classes and DB Links. 

 View details about each database object. 

 View total objects in each object type. 

 

To open Schema Explorer  

1. On the toolbar, click the icon . 

OR 

On the Tools menu, click Schema Explorer. 

 

To see details about Table 

1. Click Table node icon in object tree. 

2. Click Table name. 

 

Information about table is shown on right side. Click on each tab to view the details. 

 Columns Names, Column Attributes 

 Indexes, Index Keys 

 Details 

 Dependencies (References, Referenced by) 

 Statistics 

 Data 

 Triggers 

 Column Statistics 

 Constrains 

 Grants 

 Comments 

 

To see details about View 

1. Click View node icon  in object tree. 

2. Click View name. 

 

Information about view is shown on right side. Click on each tab to view the details. 

 Column Names, Column Attributes 

 View definition SQL 

 Data rows 

 Grants 

 Dependencies (References, Referenced by) 

 Comments 

 

To see details about Index 

1. Click Index node icon in object tree. 

2. Click Index name. 
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Information about index is shown on right side. Click on each tab to view the details. 

 Columns 

 Keys 

 

To see details about Synonym 

1. Click Synonym node icon in object tree. 

2. Click Synonym name. 

 

Information about Synonym is shown on right side. Click on each tab to view the details. 

 Synonym Details 

 Dependencies (References, Referenced by) 

 

To see details about Sequence 

1. Click Sequence node icon in object tree. 

2. Click Sequence name. 

 

Information about Sequence is shown on right side. Click on each tab to view the details. 

 Sequence details 

 Dependencies (References, Referenced by) 

 

To see details about Trigger 

1. Click Trigger node icon  in object tree. 

2. Click Trigger name. 

 

Information about Trigger is shown on right side. Click on each tab to view the details. 

 Trigger details 

 Code 

 Columns 

 Dependencies (References, Referenced by) 

 Grants 

 

To see details about Package 

1. Click Package node icon in object tree. 

2. Click Package name. 

 

Information about Package is shown on right side. Click on each tab to view the details. 

 Declaration 

 Body 

 Dependencies 

 Information 

 Grants 

 

To see details about Procedure 

1. Click Procedure node icon in object tree. 

2. Click Procedure name. 
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Information about Procedure is shown on right side. Click on each tab to view the details. 

 Code 

 Declaration 

 Information 

 Grants 

 

To see details about Function 

1. Click Function node icon in object tree. 

2. Click Function name. 

 

Information about Function is shown on right side. Click on each tab to view the details. 

 Code 

 Declaration 

 Information 

 Grants 

 

To see details about Java Source 

1. Click Java Source node icon in object tree. 

2. Click Java Source name. 

 

Information about Java Source is shown on right side. Click on each tab to view the 

details. 

 Code 

 Information 

 

To see details about Java Class 

1. Click Java Class node icon in object tree. 

2. Click Java Class name. 

 

Information about Java Class is shown on right side. Click on tab to view the details. 

 Class Details 

 

To see details about DB Links 

1. Click DB Link node icon in object tree. 

2. Click DB Link name. 

 

Information about DB Link is shown on right side. Click on tab to view the details. 

 Details 

 

 

Session Manager 

Session Manager let you see the following for each Session in a separate tab. 

 Statistics 

 Connection Information 

 Accessing (Database objects currently accessing) 

 Wait Events 
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 Blocking Sessions 

 Locked Objects 

 Open Cursors 

 Current Statement (SQL statement currently executing) 

 Previous Statement (SQL statement previously executed) 

 

Open Cursors, Current Statement and Previous Statement tabs let you see the following 

information in three sub-tabs 

o SQL Text 

o SQL Execution details 

o Explain Plan 

 

To open Session Manager 

1. On the toolbar, click the icon . 
OR 
On the Tools menu, click Session Manager. 

 

To view the details about SQL statements in each Session: 

1. Click Current Statement or Previous Statement tab. 

2. Click one of the following sub-tabs. 

a) SQL Text 

b) SQL Execution details 

c) Explain Plan  

 

To view the details about all Open Cursors and its details in each Session: 

1. Click Open Cursors tab. 

2. Click any SQL Statement from the list. 

3. Click one of the following tabs on the right half section. 

a) SQL Text 

b) SQL details 

c) Explain Plan 

 

 

Space Manager 

Space Manager let you see the following in a separate tab. 

 Tablespace tree. 

Pie chart for storage by Segment Type (User objects). 

Pie chart for Free and Used Tablespace. 

Bar graph for Free & Used Tablespace. 

 Tablespace details. 

 Tablespace File details. 

 Objects in each Tablespace. 

 Segment Type Bar graph. 

 

To open Space Manger 
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1. On the toolbar, click the icon . 
OR 
On the Tools menu, click Space Manager 

 

Note: By default Storage Used & Free Bar Graph is shown at lower left side of the Space 

Manager's Tree tab (First tab). The Options window (Navigate to Tools -> Options) let you 

choose Storage Used & Free Bar Graph or Storage by Segment Type Pie Chart at lower left side. 

Currently running Space Manager processes are not affected if you make any changes on 

Options window. Only new Space Manager processes will have the changed settings. 

 

User Manager  

User Manager let you see the following in a separate tab. 

 Profiles 

 Roles 

 Privileges 

 Role Privileges 

 Users 

 User Roles 

 User Privileges 

 

To open User Manager 

1. On the toolbar, click the icon . 
OR 
On the Tools menu, click User Manager. 

 

SGA Display 

SGA Display let you see SQL Statements from SGA shared pool. SQL Statements can be 

  Listed by  

 SQL Type (Select, Update, Insert. etc) 

 User Name 

 

Filtered by  

 SQL Text string 

 

For each SQL Statement the following information is displayed in three tabs: 

o SQL Text 

o SQL details 

o Explain Plan 

 

To open SGA Display 

1. On the toolbar, click the icon . 
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OR 
On the Tools menu, click SGA Display. 

 

 

 

Instance Details 

Instance Details let you see the following in a separate tab. 

 SGA Configuration Pie chart for Buffer Cache, Fixed SGA, Log Buffer, Java Pool, Large 

Pool, Shared Pool. 

 Instance details 

 Banner 

 Oracle Parameters 

 Hidden Parameters 

 NLS Parameters 

 Resource Limit 

 License 

 

To open Instance Details 

1. On the toolbar, click the icon . 
OR 
On the Tools menu, click Instance Details. 

 

Server Statistics 

Server Statistics let you see the following in a separate tab. 

 Statistics 

 System Waits 

 Shared Pool 

 Library Cache 

 Analyzed Stats 

 Rollback Segments 

 Blocking Sessions 

 File Activity 

 Session Activity 

 Locks 

 Wait Events 

 Waiting Sessions 

 Log History 

 Latch Details 

 Running Queries 

 Database Growth 

 Data Rows 

 DB Links 
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To open Server Statistics 

1. On the toolbar, click the icon . 
OR 
On the Tools menu, click Server Statistics. 

 

Performance Monitor 

Performance Monitor shows the condition (health) of the database instance by reading the 

system tables every 5 seconds (can be changed to any value between 5 seconds and 10 

minutes). The information is analyzed and shown in Graphs, Bar charts and Pie charts. 

Performance Monitor screen is divided into 5 sections. The sections are: 

o Top SQL (since database startup) 

o Ratios 

o System Waits  (by total time waited) 

o Calls 

o Top Sessions  (by Resource Usage, since database startup) 

 

Session counts, Commits & Rollback counts and Free/Used are shown at top potion of the 

Performance Monitor screen. 

 

Free/Used space display can be disabled by changing the default configuration setting on 

Options window (Navigate to Tools -> Options). 

 

To see more detailed information about Top SQL, open a new Top 5 SQL or Server Tuning 

window from the tool bar or Tools menu. 

To see more detailed information about System Waits, open a new System Waits window from 

the tool bar or Tools menu. 

To see more detailed information about Resource Usage, open a new Top 5 Resource or 

Resource Usage window from the tool bar or Tools menu. 

 

1) Top SQL Bar graph shows 

 Physical i/o 

 Logical i/o 

 CPU Time 

 Elapsed Time 

 

Top SQL:can be shown in three different ways and you have an option (Navigate to Tools -> 

Options) to set one of them as the default. 

 

The following are three different ways: 

1. Top SQL since database instance startup (processed by Oracle database) 

2. Top SQL since database instance startup (processed by MyOra in memory) 

3. Top SQL in current refresh interval (processed by MyOra in memory) 

 

By default Top SQL since database instance startup (processed by Oracle database) is 

enabled. 
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2) System Wait Pie chart shows 

 Top ten System Waits (by total time waited) in last 5 seconds 

 

3) Ratios graph shows 

 Buffer Cache Hit ratio 

 Library Cache Hit ratio 

 Directory Cache Hit ratio 

 Memory Sort ratio 

 Parse/Execute ratio 

 

4) Calls graph shows 

 Execute Counts (refreshes every 5 seconds) 

 

5) Top Sessions (by Resource Usage) shows  

 Physical i/o 

 Logical i/o 

 CPU 

 Memory 

 

To open Performance Monitor 

1. On the toolbar, click the icon . 
OR 
On the Tools menu, click Performance Monitor. 

 

Note: By default the Refresh Button  and Refresh Interval selection dropdown list on 

Performance Monitor screen are enabled. The Options window (Navigate to Tools -> 

Options) let you disable Refresh Button and Refresh Interval selection. 

 

If you choose to disable Refresh Button  and Refresh Interval selection list, then you 

need to set Refresh Interval between 5 seconds and 10 minutes on Options window.  

 

Currently running Performance Monitor processes are not affected if you make any changes on 

Options window. Only new Performance Monitor processes will have the changed settings. 

 

System Waits 

System wide waits are shown as percentage of total waits. Top ten System waits are shown in a 

Pie chart. System Waits are retrieved from the database system tables for every 5 seconds (can 

be changed to any value between 5 seconds and 10 minutes). Session waits are shown by 

choosing the desired Session Id from the dropdown box (filter by session id). 
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System Waits let you see the following 

 System Waits (by Total time waited). 

o Time Waited 

o Delta value 

o % Total Time Waited 

  

 System Waits (by Total number of waits). 

o Number of Times Waited 

o Delta value 

o % Total Waits 

 

To open System Waits 

1. On the toolbar, click the icon . 
OR 
On the Tools menu, click System Waits. 

 

 

Note: By default Refresh Interval is being set to 5 seconds. The Refresh Interval can be set 

between 5 seconds and 10 minutes on Options window (Navigate to Tools -> Options). 

 

Currently running System Waits processes are not affected if you make any changes on 

Options window. Only new System Waits processes will have the changed settings. 

 

 

Top 5 SQL  

Top 5 SQL shows Physical i/o, Logical i/o, CPU Time and Elapsed Time of 5 top SQL statements 

in each of these categories since database startup. The Top 5 SQL window has two sections. 

Left side section shows 3-D interactive bar graph for Physical i/o, Logical i/o, CPU Time and 

Elapsed Time. The right side section shows SQL text, SQL details and SQL explain plan. 

 

Each vertical bar represents one SQL statement and height of the vertical bar represents percent 

of Physical i/o or Logical i/o or CPU Time or Elapsed Time. 

 Place the mouse over any vertical bar to see the percentage. 

 Click on any vertical bar to see SQL text, SQL details and SQL explain plan. 

 

Place the mouse over the text Physical i/o or Logical i/o or CPU Time or Elapsed Time to see 

Top 5 SQLs in the respective categories (base of vertical bar changes to light Blue color to 

indicate Top 5 SQLs). 

 

Place the mouse over the text Top1 SQL or Top2 SQL or Top3 SQL or Top4 SQL or Top5 SQL to 

see Top SQLs in the each category (base of vertical bar changes to light Green color to indicate 

SQLs). 

. 
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Top 5 SQL let you see the following 

 Physical i/o 

 Logical i/o 

 CPU Time 

 Elapsed Time 

 

To open Top 5 SQL 

 On the toolbar, click the icon . 
OR 
On the Tools menu, click Top 5 SQL. 

 

Server Tuning  

For each SQL statement, Server Tuning shows percentage of Physical i/o, Logical i/o, CPU 

Time and Elapsed Time of all SQL statements that are executed since database startup. The 

window is divided into four sections. Each section shows SQL Analysis for Physical i/o, Logical 

i/o, CPU Time and Elapsed Time respectively. Data rows in each section are sorted by percent 

highest value to lowest value. 

 

Each section is color coded with small colored block at top left corner. These block colors 

matches with Top SQL graph’s legend in Performance Monitor.  

 

To see details of each SQL statement 

 Click the mode change icon  to show data rows from a single section.  

 Click desired SQL Statement to see details on the right side. 

 

Click the icon to see all four sections. The icons  and  will allow to you to toggle 

between four sections and one section. 

 

Server Tuning let you see the following 

 Physical i/o – SQL Text, Disk Reads, Percent, SQL Address & Hash value  

 Logical i/o – SQL Text, Buffer Gets, Percent, SQL Address & Hash value   

 CPU Time  – SQL Text, CPU Time, Percent, SQL Address & Hash value 

 Elapsed Time  – SQL Text, Elapsed Time, Percent, SQL Address & Hash value 

 

To open Server Tuning 

1. On the toolbar, click the icon . 
OR 
On the Tools menu, click Server Tuning.  

 

Top 5 Resource  

Top 5 Resource shows Physical i/o, Logical i/o, CPU and Memory of 5 top resource using 

Sessions (users or processes) in each of these categories since database startup. The Top 5 

Resource window has two sections. Left side section shows 3-D interactive bar graph for 
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Physical i/o, Logical i/o, CPU and Memory. The right side section shows Resource Statistics for 

each session. 

 

Each vertical bar represents one Session and height of the vertical bar represents percent of 

Physical i/o or Logical i/o or CPU or Memory used. 

 Place the mouse over any vertical bar to see the percentage. 

 Click on any vertical bar to see Resource usage details on the right side. 

 

Place the mouse over the text Physical i/o or Logical i/o or CPU or Memory to see Top 5 

Resource Usage sessions in the respective categories (base of vertical bar changes to light Blue 

color to indicate Top 5 Resource Using sessions). 

 

Place the mouse over the text Top1 Resource or Top2 Resource or Top3 Resource or Top4 

Resource or Top5 Resource to see Top Resource Using sessions in the each category (base of 

vertical bar changes to light Green color to indicate Sessions). 

 

 

Top 5 Resource let you see the following 

 Physical i/o 

 Logical i/o 

 CPU 

 Memory 

 

To open Top 5 Resource 

 On the toolbar, click the icon . 
OR 
On the Tools menu, click Top 5 Resource. 

 

 

Resource Manager 

Resource Manager shows percentage of Physical i/o, Logical i/o, CPU and Memory usage of all 

resource using Sessions (users or processes) in each of these categories since database startup. 

Also shows all Resource Usage details of each Session. 

 

The window is divided into four sections. Each section shows Resource Usage for Physical i/o, 

Logical i/o, CPU and Memory respectively. Data rows in each section are sorted by percent 

highest value to lowest value.  

 

Each section is color coded with small colored block at top left corner. These block colors 

matches with Top Sessions (Resource Usage) legend in Performance Monitor.  

 

 To see Resource Usage details of each session 

 Click the mode change icon  to see data rows from one section. 

 Click desired Session row to see details in the right side. 

 



MyOra 6.0 Jayam Systems LLC  Page 27 of 36 

 

Click the icon to see all four sections. The icons  and  will allow you to toggle between 

four sections and one section.  

 

Resource Manager let you see the following 

 Physical i/o 

 Logical i/o 

 CPU 

 Memory 

 

To open Resource Manager 

 On the toolbar, click the icon . 
OR 
On the Tools menu, click Resource Manager. 

 

DB Activity 

DB Activity shows database activity in real time using interactive graphs. The Refresh Interval 

for DB Activity process can be set between 5 seconds and 10 minutes on Options window. DB 

Activity window is divided into 6 graphs. Each graph shows information about:  

o Logical I/O 

o Physical I/O 

o Call Rate 

o Event Waits 

o Latch Misses 

o Sessions 

 

1) Logical I/O graph shows 

 db block changes 

 db block gets 

 consistent gets 
 

2) Physical I/O graph shows 

 physical writes 

 physical reads 

 redo writes 

 

3) Call Rate graph shows 

 execute count 

 user commits 

 user rollbacks 

 parse count (hard) 

 parse count (total) 

 

4) Sessions graph shows 

 active sessions 

 inactive sessions 
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 total sessions 

 

5) Event Waits graph shows 

 time waited 

 

6) Latch Misses graph shows 

 latch misses 

To see more detailed information about Event Waits, open a new System Waits window from the 

tool bar or Tools menu. 

To open DB Activity 

1.  On the toolbar, click the icon     . 

     OR 

     On the Tools menu, click DB Activity. 

 

Each graph has Graph Types which can be selectable by placing the cursor over the small 

rectangle boxes (located left side of each graph). 

To select Graph Type (for each graph) 

 Graph type let you select the required graph (for example Logical I/O graph has three 

individual moving graphs, each graph corresponding to db block changes, db block gets 

and consistent gets). You can select one of the three moving graphs by placing the 

cursor over the empty rectangle box, then box is filled with a color dot corresponding to 

Graph Type. Now place the cursor on the graph area, a small dot is shown on the graph 

and the value corresponding to the Graph Type is shown on the top of the graph. 

To see Graph Values at any given time 

 Place the cursor over the graph area. A small dot is shown on the graph and value is 

shown on the top of the graph.  If the cursor is moved across the graph area, the dot is 

also moved across the graph and values are shown on the top of the graph. 

 Note: Wait Events graph shows Top 5 wait events and % total time waited (at left side of graph). 

Latch Misses graph shows Top 5 latch misses and % total number of misses (at left side 
to graph). 

 

To see One Graph 

 Click on One Graph rectangle box to see the graph corresponding to the Graph Type 

selected. 

To see All Graphs 

 Click on All Graphs rectangle box to see all graphs.  
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Note: By default Refresh Interval is being set to 5 seconds. The Refresh Interval can be set 

between 5 seconds and 10 minutes on Options window (Navigate to Tools -> Options). 

Currently running DB Activity processes are not affected if you make any changes on Options 

window. Only new DB Activity processes will have the changed settings. 

 

Wait Analysis 

Wait Analysis shows mostly Wait Class details, CPU Usage, Events, Objects, Sessions and 

SQL statements. Wait Analysis screen is divided into two sections. The upper section shows 

Wait Time Bar graph and the lower section shows Activity for Events, Sessions, Objects and SQL 

statements. 

 

Note: 

 MyOra does not access Active Session History or ASH table. 

 MyOra does not access Automatic Workload Repository or AWR tables. 

 MyOra does not access DBA history tables. 

 

 

Wait Analysis works with Oracle 10g, 11g and 12c. 

 

Wait Analysis will allow you to examine and perform detailed analysis on Events, Sessions, 

Objects and SQL statements. Wait Analysis cannot show SQL information, if SQL statements 

are flushed from SQL Area. 

 
 

The bar graph shows: 

 Time Waited values for each Wait Class within last 30 minutes (or within last 5 days). 

The lower section shows: 

 Events, Sessions, Objects and SQL statements within last 30 minutes (or within last 5 

days). 

 

 

Note: Wait Analysis screen must be running (should not be closed) to see Time Waited values, 

Events, Sessions, Objects and SQL statements. 

 

By default Refresh Interval is being set to 30 seconds. The Refresh Interval can be set between 

30 seconds and 120 minutes (2 hours) on Options window (navigate to Tools -> Options). If you 

choose Refresh Interval of 120 minutes (2 hours), then you can see Wait Time analysis for last 5 

days. 

 

You can also run multiple Wait Analysis screens for same database with different Refresh 

Intervals. Always choose desired Refresh Interval on Options window before starting Wait 

Analysis screen. 
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Bar graph is based on actual time interval on X axis and Time Waited value on Y axis. Wait 

details for a time interval can be analyzed. While analyzing the bar graph, ‘CPU Usage’ value 

must read as ‘CPU Time’ (not CPU wait time). Idle events are excluded from the Wait Analysis. 

 

 

The bar graph displays Time Waited value for following Wait Classes: 

 Queueing 

 User I/O 

 System I/O 

 Scheduler 

 Others 

 Cluster 

 Network 

 Configuration 

 Concurrency 

 Commit 

 Application 

 Administrative 

 CPU Usage (CPU Time, not an wait event) 

 

 

The lower section detailed information. 

 

 Events 

a) Event Name 

b) Class Name 

c) Value% 

 

 Objects 

a) Owner 

b) Object Name 

c) Object Type 

d) Statistics Name 

e) Value% 

 

 Sessions 

a) Sid 

b) Serial# 

c) User Name 

d) Machine 

e) Terminal 

f) OS User 

g) Program 

h) CPU Usage% 

 

 SQL Statements 

a) SQL Text 

b) SQL Id 
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c) CPU Time% 

 

 

To open Wait Analysis 

 On the toolbar, click the icon . 

OR 

On the Tools menu, click Wait Analysis. 

 

 

To see Wait Details for one time interval 

 On the bar graph, click on any vertical bar. 

 A vertical line appears along the vertical bar and an blue color arrow is shown on X-axis 

to indicate time interval. 

 In the lower section, %Activity is shown for Events, Objects, Sessions and SQL 

statements for the selected time interval. 

 

 

To see Wait Details for a range of Time interval 

 To select a range of Time interval, on the bar graph, click on any vertical bar and drag the 

cursor to either left or to right (similar to selecting the text in any word document). 

 A transparent area is shown for the selected Time interval (range). Two blue color arrows 

are shown on the X-axis to indicate Begin time and End time of selected time interval. 

 %Activity is shown for Events, Objects, Sessions and SQL statements in the lower 

section for range of Time interval. 

 

 

Currently running Wait Analysis screens (processes) are not affected if you make any changes 

on Options window. Only new Wait Analysis screens will have the changed settings. 

 

Top Ten SQL 

Shows Top Ten SQLs in nine different categories using interactive 2-D / 3-D pie charts. These 
categories are disk reads, buffer gets, cpu time, elapsed time, direct writes, sharable mem, 
executions, fetches, rows processed. Top Ten SQLs are retrieved from the database system 
tables for every 5 seconds (can be changed to any value between 5 seconds and 10 minutes). 
 
Each 2-D/3-D interactive pie chart is responsive to cursor. The SQL id and percentage values for 

each SQL is listed left of pie chart. If you place the cursor on SQL Id, then the first 60 character of 

SQL text is shown. 

 

Top Ten SQL works with Oracle 10g, 11g and 12c. 

 

Top Ten SQL let you see the following 

 disk reads 

 buffer gets 

 cpu time 

 elapsed time 

 direct writes 
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 sharable mem 

 executions 

 fetches 

 rows processed 

 

 

To open Top Ten SQL 

 On the toolbar, click the icon . 

OR 

On the Tools menu, click Top Ten SQL. 

 

 

To see SQL Text 

 Click on SQL rectangle box to select SQL check box and place the cursor on SQL Id to 

see SQL text. 

 

To see Related values of the SQL Id 

 Click on Related rectangle box to select Related check box and place the cursor on SQL 

Id to see values of disk reads, buffer gets, cpu time, elapsed time, direct writes, sharable 

mem, executions, fetches and rows processed. 

 

Currently running Top Ten SQL processes are not affected if you make any changes on Options 

window. Only new Top Ten SQL processes will have the changed settings. 

 

Blockers Waiters 

Blockers Waiters shows Session Blockers, Session Waiters, Locks and Long Running Queries. 

Also shows all Resource Usage details of each Session. 

 

The window is divided into four sections. Each section shows Session Blockers, Session Waiters, 

Locks and Long Running Queries respectively. Data rows in each section are sorted by User 

Name. 

 

Each section is color coded with small colored block at top left corner.  

 

 To see Resource Usage of each session 

 Click the mode change icon  to see data rows from one section. 

 Click desired Session row to see details in the right side. 

 

Click the icon to see all four sections. The icons  and  will allow you to toggle between 

four sections and one section.  

 

Blockers Waiters let you see the following 

 Physical i/o 

 Logical i/o 

 CPU 
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 Memory 

 

To open Blockers Waiters 

 On the toolbar, click the icon . 
OR 
On the Tools menu, click Blockers Waiters. 

 

 

Options Window 

Currently running processes are not affected if you make any changes on Options window 

(except the date format change in SQL editor). Only new processes (new screens) will have the 

changed configuration settings. 

All the changes made on Options window will be saved to Configuration file except SQL 

Editor’s Result Grid Date format change. 

You can use Options window to change the default configuration settings of SQL Editor, Space 

Manager, Performance Monitor, DB Activity and System Waits screens. The left pane of the 

Options window contains a tree view of above features. The right pane displays the default 

settings or default values for the selected feature from the tree. 

 

To open Options window 

 On the Tools menu, click Options. 

 

SQL Editor settings 

1. Result Grid Date format 

The default date format for SQL Editor’s Result grid is DD-Mon-YYY. 

 

You can change the default date format by selecting the desired date format from drop 

down list. 

 

Space Manager settings 

By default Storage Used & Free Bar Graph is Enabled, this means Storage Used & Free 

Bar Graph is shown at lower left side of Space Manager's Tree tab. 

 

By clicking the appropriate radio button you can choose Storage Used & Free Bar Graph 

or Storage by Segment Type Pie Chart as the default setting. 
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Performance Monitor settings 

General Tab 

a) By default Refresh Button  and Refresh Interval selection dropdown list are 

enabled. 

b) If you choose to disable Refresh Button  and Refresh Interval selection list, 

then you need to set Refresh Interval between 5 seconds and 10 minutes. In 

disable Refresh Button mode, the Call graph and Ratios graph will show Time 

scale on X-axis. 

 

Top SQL Tab 

You can choose any one of the three options 

 

Top SQL since database instance startup (processed by Oracle 

database) 

Top SQL since database instance startup (processed by MyOra in 

memory) 

Top SQL in current refresh interval (processed by MyOra in memory) 

 

By default Top SQL since database instance startup (processed by Oracle 

database) is enabled. 

 

Space Used/Free Tab 

By default Show Used/Free is selected, this means Space Used / Free values 

are shown on top right portion of Performance Monitor screen. 

 

System Waits settings 

The default Refresh Interval is being set to 5 seconds. You can change default Refresh 

Interval between 5 seconds and 10 minutes. 

 

DB Activity settings 

The default Refresh Interval is being set to 5 seconds. You can change default Refresh 

Interval between 5 seconds and 10 minutes. 

 

Wait Analysis settings 

The default Refresh Interval is being set to 30 Seconds. You can change default Refresh 

Interval between 30 seconds and 120 minutes (2 hours). 

 

Text on X-axis (Begin Time and End Time) by default shown in inclined direction. You can 

change the direction to Straight. 
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Top Ten SQL settings 

The default Refresh Interval is being set to 5 Seconds. You can change default Refresh 

Interval between 5 seconds and 10 minutes. 

 

You can choose any one of the two options. 

1. Top Ten SQLs since database instance startup (processed by MyOra in memory) 

2. Top Ten SQLs in current refresh interval (processed by MyOra in memory) 

 

By default Top Ten SQLs since database instance startup is enabled. 

 

All the changes made on Options window will be saved to a configuration file except SQL 

Editor’s Result Grid Date format change. 

 

MyOra Console 

MyOra has 18 different modules (screens), the main purpose of MyOra Console is to show all 

active modules at once in a easy accessible manner. MyOra Console shows all active modules in 

form of icons. Each icon represents one module and at the middle of each icon module code is 

shown. (Please refer module codes and module names below). If you click on an icon, the 

module corresponding to the module code will be activated. 

If there is more than one active connection for a given module, then the total number of active 

connections will be shown at the top right corner of the icon. If you click on an icon with multiple 

active connections, means an icon with a number on top right corner, then the icon will explode 

into individual connections and each icon will represent one connection. 

Note: On MyOra Console the maximum active connection display limit is 16 for any module. In 

general, MyOra can have up to 100 active connections (for a single module or combination of 

modules), but on Console only the first 16 connections of a module will be shown. 

 

To open MyOra Console 

 On the Window menu, click Console. 

OR 
Press ALT + B 

 

To refresh MyOra Console press Refresh Button on Console. 

 

To remove MyOra Console from screen press ESC key. 

 

MyOra module codes on Console 

Se SQL Editor 

Sx Schema Explorer 

Sm Session Manager 
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Pm Performance Monitor 

Sw System Waits 

St Server Tuning 

Sp Space Manager 

Um User Manager 

Sg SGA Display 

Id Instance Details 

Ss Server Statistics 

Rm Resource Manager 

Tr Top 5 Resource 

Ts Top 5 SQL 

Da DB Activity 

Wa Wait Analysis 

Tt Top Ten SQL 

Bw Blockers Waiters 

Te Text Editor 

 

The bottom row of the Console has four anchor icons which corresponds to four modules, these 

modules are SQL Editor, Schema Explorer, Session Manager and Performance Monitor. The 

anchor icons are always shown at the same location on Console. If there is no active module 

corresponding to anchor icons, then that icon will not be shown. 

 


